anonymous Log in
Search
Recents:
v3.0
sd
Error al compilar iOS (.pbxproj)
22/09/20 13:42

Paulo Andrés Sa88723

Replies: 4

Al compilar mi APP en iOS con Gx16U10 y xCode 11.5 me esta dando el
siguiente error
========== iOS Compilation started ==========
Command: MacTransfer BuildApp /env "Java Environment" /h "172.31.252.223"
/kb "SmartDeviceAutogestion_PROD" /m
"C:\Sistemas\Gx16\SmartDeviceAutogestion_PROD\JavaModel" /o "sdpLogin" /p
<password> /u "usuario" /v "16.0.142546 U10"
Connecting to 172.31.252.223
Copying Libraries to /Users/usuario/Library/GeneXus/GeneXus/16.0.142546_U10/
Synchronizing
C:\Sistemas\Gx16\SmartDeviceAutogestion_PROD\JavaModel\mobile\iOS\sdpLogin\ios\Genexus
to /Users/usuario/Documents/Projects/SmartDeviceAutogestion_PROD/Java
Environment/sdpLogin
Compiling
sshExec: cd ~/Documents/Projects/SmartDeviceAutogestion_PROD/Java\
Environment/sdpLogin;/Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild
-scheme "sdpLogin" -destination "generic/platform=iOS Simulator"
-configuration Debug build SYMROOT=\$PWD/build 2>&1
error: xcodebuild: error: Unable to read project 'sdpLogin.xcodeproj'.
Failed: iOS Compilation
Failed: Run sdpLogin
También si intento abrir el proyecto desde xCode me da lo siguiente
[image: image.png]
¿Qué puede estar pasando? ¡Gracias!
Paulo
Replies

finthamoussu

22/09/20 14:14
El problema parece ser que el proyecto Xcode generado no tiene el formato correcto al intentar compilarlo / abrirlo. Probablemente se deba a un error anterior en la generación que no está terminando con éxito. No ves algún otro error anterior en el output del armado? Saludos, Fabian Inthamoussu R&D Team | GeneXus +598 2601 2082 | Simplifying Software Development > El 22 sept 2020, a las 15:42, Paulo Sapuppo

Paulo Andrés Sa88723

22/09/20 14:23
Hola Fabian, si, efectivamente encontré este error... Applying Bootstrapping for:sdpLogin error: Custom launch screen file '' not found. ('Apple Launch Screen' of Panel for Smart Devices 'sdpLogin') iOS Failed Failed: SmartDevices (Smart Devices) Generation Será esto el causante? Tengo la propiedad vacía, tenia entendido que si estaba vacía tomaba uno default, si no es así ¿cómo puedo generar uno? Gracias! Paulo El mar., 22 de sep. de 2020 a la(s) 11:14, Fabian Inthamoussu ( finthamoussu@genexus.com)

finthamoussu

22/09/20 14:28
> Será esto el causante? Tengo la propiedad vacía, tenia entendido que si estaba vacía tomaba uno default, si no es así ¿cómo puedo generar uno? Si, con darle botón derecho y “Use Default” a esa propiedad (Apple Launch Screen) debería corregir el problema. Fabian Inthamoussu R&D Team | GeneXus +598 2601 2082 | Simplifying Software Development > El 22 sept 2020, a las 16:23, Paulo Sapuppo

Paulo Andrés Sa88723

22/09/20 14:34
Efectivamente era eso... Gracias! El mar., 22 de sep. de 2020 a la(s) 11:28, Fabian Inthamoussu ( finthamoussu@genexus.com)


Back to sd