anonymous Log in
Search
Recents:
v3.0
sd
Anuncio: (In)compatibilidad con Xcode 11.2
01/11/19 20:21

mcrispino

Replies: 3

El pasado 31 de octubre (ayer) Apple liberó la versión 11.2 de Xcode que
incluye Swift 5.1.2 que *no es compatible* con las versiones anteriores. .
Recomendamos no actualizar la versión de Xcode a la 11.2, ya que la misma
no es compatible con las aplicaciones iOS generadas por las versiones
liberadas hasta ahora de GeneXus, las mismas dejan de compilar. Si ya
actualizó, deberá descargar a instalar Xcode 11.1 desde el sitio
developer.apple.com <https://developer.apple.com/download/more/>.
Estamos trabajando para agregar soporte a Xcode 11.2 en la versión Beta de
GeneXus y en el *preview* del Upgrade 7, lo que estará disponible en los
próximos días. Los mantendremos al tanto de las novedades.
Como siempre, pueden verificar las versiones requeridas y soportadas en la
página del Wiki: iOS Requirements
<https://wiki.genexus.com/commwiki/servlet/wiki?19478,iOS+Requirements,>.
Saludos.
Replies

guscarr

06/11/19 12:19
Allan, Estamos en el proceso de testing de los cambios, esperamos que estén a la brevedad. Como dato relevante es que se puede tener más de una instalación de XCode y elegir cual utilizar: https://wiki.genexus.com/commwiki/servlet/wiki?29380,How%20To%3A%20Change%20the%20Xcode%20version%20used%20by%20GeneXus Con lo cual podés tener la 11.1 y 11.2 instaladas y usar la que corresponde. Digo esto porque otro dato relevante es que la 11.2 no es backward compatible con lo cual si tienes proyectos con U6 vas a tener que conservar la 11.1 Saludos e informamos por este medio los avances, Gustavo *

afuentes11878

06/11/19 12:04
Hola Marcos, Se tendrán noticias del preview que soporta la versión 11.2 de Xcode? Gracias, Saludos Allan > On 1 Nov 2019, at 14:21, Marcos Crispino

guscarr

06/11/19 19:30
Estimados, Agregamos soporte de XCode 11.2 en la beta a partir del build 137019 y el actualmente publicado es 137042 así que para esa versión ya está disponible. En cuanto a la linea preview fue agregado en el build 137073 que aun no ha sido publicado pero será publicado a la brevedad. Recordar que no es backward compatible por lo cual si continúan usando U6 se debe mantener la instalación de XCode 11.0 u 11.1 y elegir cual utilizar en cada caso: https://wiki.genexus.com/commwiki/servlet/wiki?29380,How%20To%3A%20Change%20the%20Xcode%20version%20used%20by%20GeneXus Saludos, Gustavo Carriquiry *


Back to sd