anonymous Log in
Search
Recents:
v3.0
xev2
IOS SDK 5.0
10/07/12 17:23

PuntoExe | Ing. Juan

Replies: 14


Hola:



Discuplas por mi ignorancia pero recién estoy comenzando con
las pruebas de Mac.

Ya me bajé el XCode 4.3.2.

Ya hice las configuraciones en el Mac para habilitar ssh.

Cuando estoy con el F5 con Mac me sale el siguiente mensaje:



\========== iOS Compilation started ==========

Command:MacTransfer compile "192.168.0.100" "genexus" "<password>"
"PXToolsDemo" "PXToolsDemo" "IPhoneSim" "P:\GeneXus X
Ev2\PuntoExe\PXToolsDemo\Java"

Connecting to 192.168.0.100

error: iOS SDK 5.0 or later not found

iOS Compilation Failed



¿Como instalo el IOS SDK? Supuestamente ya viene en el XCode
pero la verdad que no tengo idea de cómo verificar si está o no está.



Saludos




Ing. Juan Marcelo Bustamante Lamas
Gerente de Proyectos

PuntoExe Consultores
www.puntoexe.com.uy
Tel: (598-2) 3366612
MSN: ijmbl@hotmail.com
Skype: jmblamas


<http://www.puntoexe.com.uy/>
http://www.puntoexe.com.uy/sites/puntoexe/firmas/puntologomail.jpg


<http://www.genexus.com/portal/hgxpp001.aspx?2,51,813,O,S,0,,>
http://www.puntoexe.com.uy/sites/puntoexe/firmas/platformpartner.jpg





<http://www.pxtools.com.uy/>
http://www.puntoexe.com.uy/sites/puntoexe/firmas/pxlogomail.jpg

Migración Win a Web
Programación de alto nivel
Conocimiento Web Acumulado
<http://www.pxtools.com.uy> www.pxtools.com.uy


La solución en desarrollo y
mantenimiento de sitios web
<http://www.epiway.com/> www.epiway.com

<http://www.epiway.com/>
http://www.puntoexe.com.uy/sites/puntoexe/firmas/epiwaylogomail.jpg





Replies

Diego Rostagnol

10/07/12 17:25
Creo que son cosas separadas, el xCode y el iOS SDK. Saludos. [image: GXBus Logo] * http://www.facebook.com/GXBus* *Entrá en la página y hacé click en "Me Gusta" para apoyar el proyecto* 2012/7/10 PuntoExe | Ing. Juan Marcelo Bustamante Lamas < jmbl@puntoexe.com.uy> > Hola:**** > > ** ** > > Discuplas por mi ignorancia pero recién estoy comenzando > con las pruebas de Mac.**** > > Ya me bajé el XCode 4.3.2.**** > > Ya hice las configuraciones en el Mac para habilitar ssh.* > *** > > Cuando estoy con el F5 con Mac me sale el siguiente > mensaje:**** > > ** ** > > \========== iOS Compilation started ==========**** > > Command:MacTransfer compile "192.168.0.100" "genexus" "" > "PXToolsDemo" "PXToolsDemo" "IPhoneSim" "P:\GeneXus X > Ev2\PuntoExe\PXToolsDemo\Java"**** > > Connecting to 192.168.0.100**** > > error: iOS SDK 5.0 or later not found**** > > iOS Compilation Failed**** > > ** ** > > ¿Como instalo el IOS SDK? Supuestamente ya viene en el > XCode pero la verdad que no tengo idea de cómo verificar si está o no está. > **** > > ** ** > > Saludos**** > > ** ** > > *Ing. Juan Marcelo Bustamante Lamas* > *Gerente de Proyectos* > > *PuntoExe Consultores* > www.puntoexe.com.uy > Tel: (598-2) 3366612 > MSN: ijmbl@hotmail.com > Skype: jmblamas **** > > [image: http://www.puntoexe.com.uy/sites/puntoexe/firmas/puntologomail.jpg] > **** > > [image: > http://www.puntoexe.com.uy/sites/puntoexe/firmas/platformpartner.jpg] > **** > ------------------------------ > > [image: http://www.puntoexe.com.uy/sites/puntoexe/firmas/pxlogomail.jpg] > **** > > *Migración Win a Web** > **Programación de alto nivel** > **Conocimiento Web Acumulado** > **www.pxtools.com.uy***** > > *La solución en desarrollo y** > **mantenimiento de sitios web** > **www.epiway.com***** > > [image: > http://www.puntoexe.com.uy/sites/puntoexe/firmas/epiwaylogomail.jpg] > **** > ------------------------------ > > ** ** >

PuntoExe | Ing. Juan

10/07/12 17:30
Diego: El problema es que estoy buscando “ios sdk� solo está el xcode y otras 3 aplicaciones que no corresponden. ¿De dónde bajo el ios? Saludos Ing. Juan Marcelo Bustamante Lamas Gerente de Proyectos PuntoExe Consultores www.puntoexe.com.uy Tel: (598-2) 3366612 MSN: ijmbl@hotmail.com Skype: jmblamas http://www.puntoexe.com.uy/sites/puntoexe/firmas/puntologomail.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/platformpartner.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/pxlogomail.jpg Migración Win a Web Programación de alto nivel Conocimiento Web Acumulado www.pxtools.com.uy La solución en desarrollo y mantenimiento de sitios web www.epiway.com http://www.puntoexe.com.uy/sites/puntoexe/firmas/epiwaylogomail.jpg

Diego Rostagnol

10/07/12 17:44
mmm... Por que no probas con el xCode 4.2?? Tenes Lion o Leopard ?? Saludos. [image: GXBus Logo] * http://www.facebook.com/GXBus* *Entrá en la página y hacé click en "Me Gusta" para apoyar el proyecto* 2012/7/10 PuntoExe | Ing. Juan Marcelo Bustamante Lamas < jmbl@puntoexe.com.uy> > Diego:**** > > ** ** > > El problema es que estoy buscando “ios sdk� solo está el > xcode y otras 3 aplicaciones que no corresponden.**** > > ¿De dónde bajo el ios?**** > > ** ** > > Saludos**** > > ** ** > > *Ing. Juan Marcelo Bustamante Lamas* > *Gerente de Proyectos* > > *PuntoExe Consultores* > www.puntoexe.com.uy > Tel: (598-2) 3366612 > MSN: ijmbl@hotmail.com > Skype: jmblamas **** > > [image: http://www.puntoexe.com.uy/sites/puntoexe/firmas/puntologomail.jpg] > **** > > [image: > http://www.puntoexe.com.uy/sites/puntoexe/firmas/platformpartner.jpg] > **** > ------------------------------ > > [image: http://www.puntoexe.com.uy/sites/puntoexe/firmas/pxlogomail.jpg] > **** > > *Migración Win a Web** > **Programación de alto nivel** > **Conocimiento Web Acumulado** > **www.pxtools.com.uy***** > > *La solución en desarrollo y** > **mantenimiento de sitios web** > **www.epiway.com***** > > [image: > http://www.puntoexe.com.uy/sites/puntoexe/firmas/epiwaylogomail.jpg] > **** > ------------------------------ > > ** ** > > *

ggonzalez

10/07/12 17:59
En realidad, van de la mano tengo entendido... Para instalar el iOS SDK necesitas que la versión de tu mac sea como mínimo 10.7.3 si mal no recuerdo (codename mac os lion). Si estas en ios 10.6.8 tienes primero que actualizarte a 10.7.3 0 10.7.4 y luego te deja instalar el ios sdk 5 El 10 de julio de 2012 16:24, Diego Rostagnol

PuntoExe | Ing. Juan

10/07/12 18:05
Tengo Lion. Según lo que estuve investigando encontré el SDK dentro del paquete del xcode (Applicaciones/Xcode): Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.1.sdk ¿Donde lo está buscando GeneXus? Saludos Ing. Juan Marcelo Bustamante Lamas Gerente de Proyectos PuntoExe Consultores www.puntoexe.com.uy Tel: (598-2) 3366612 MSN: ijmbl@hotmail.com Skype: jmblamas http://www.puntoexe.com.uy/sites/puntoexe/firmas/puntologomail.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/platformpartner.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/pxlogomail.jpg Migración Win a Web Programación de alto nivel Conocimiento Web Acumulado www.pxtools.com.uy La solución en desarrollo y mantenimiento de sitios web www.epiway.com http://www.puntoexe.com.uy/sites/puntoexe/firmas/epiwaylogomail.jpg

PuntoExe | Ing. Juan

10/07/12 18:15
Guillermo: Tengo instalado el 10.7.4. ¿Alguna idea? Ing. Juan Marcelo Bustamante Lamas Gerente de Proyectos PuntoExe Consultores www.puntoexe.com.uy Tel: (598-2) 3366612 MSN: ijmbl@hotmail.com Skype: jmblamas http://www.puntoexe.com.uy/sites/puntoexe/firmas/puntologomail.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/platformpartner.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/pxlogomail.jpg Migración Win a Web Programación de alto nivel Conocimiento Web Acumulado www.pxtools.com.uy La solución en desarrollo y mantenimiento de sitios web www.epiway.com http://www.puntoexe.com.uy/sites/puntoexe/firmas/epiwaylogomail.jpg

mazzone.diego

10/07/12 18:21
Cuando dices que encontraste el sdk en: "Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.1.sdk" te refieres a que estas buscando adentro del .app? Una vez instalado el Xcode, la ubicación del simulador queda en: /Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/ Probá abrir el Xcode, crear un proyecto nuevo (en blanco) y correrlo en el simulador de iPhone para descartar tengas todo bien instalado en la Mac. Saludos, Diego El 10 de julio de 2012 17:07, PuntoExe | Ing. Juan Marcelo Bustamante Lamas

ggonzalez

10/07/12 18:23
Y cuando abris el xcode dentro de mac y pones "about" te dice la version correcta? Te debe informar versión de xcode y del SDK. Otra cosa que tenés que probar es borrar el folder Lybrary/Artech y darle F5 de nuevo. Ese folder creo que está bajo el folder correspondiente al usuario actual de mac El 10 de julio de 2012 17:07, PuntoExe | Ing. Juan Marcelo Bustamante Lamas

PuntoExe | Ing. Juan

10/07/12 18:42
Si, exacto. Lo veo dentro del .app. Probé crear un proyecto en blanco e hice el run y ejecuta el simulador. La carpeta /Developer no la tengo. ¿Alguna idea? Ing. Juan Marcelo Bustamante Lamas Gerente de Proyectos PuntoExe Consultores www.puntoexe.com.uy Tel: (598-2) 3366612 MSN: ijmbl@hotmail.com Skype: jmblamas http://www.puntoexe.com.uy/sites/puntoexe/firmas/puntologomail.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/platformpartner.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/pxlogomail.jpg Migración Win a Web Programación de alto nivel Conocimiento Web Acumulado www.pxtools.com.uy La solución en desarrollo y mantenimiento de sitios web www.epiway.com http://www.puntoexe.com.uy/sites/puntoexe/firmas/epiwaylogomail.jpg

PuntoExe | Ing. Juan

10/07/12 18:52
Encontré esta información: http://stackoverflow.com/questions/9539449/developer-directory-is-missing-on -lion-xcode-4-3 Parece que el XCode no genera más ese directorio. ¿GeneXus estará buscando en ese directorio? Saludos Ing. Juan Marcelo Bustamante Lamas Gerente de Proyectos PuntoExe Consultores www.puntoexe.com.uy Tel: (598-2) 3366612 MSN: ijmbl@hotmail.com Skype: jmblamas http://www.puntoexe.com.uy/sites/puntoexe/firmas/puntologomail.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/platformpartner.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/pxlogomail.jpg Migración Win a Web Programación de alto nivel Conocimiento Web Acumulado www.pxtools.com.uy La solución en desarrollo y mantenimiento de sitios web www.epiway.com http://www.puntoexe.com.uy/sites/puntoexe/firmas/epiwaylogomail.jpg

finthamoussu

10/07/12 19:12
GeneXus lo que hace para buscar los SDK correspondientes es con el siguiente comando: /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild -version -sdk y de la salida de este comando busca iPhoneOSX.X.sdk donde X.X tiene que ser una versión mayor o igual a 5.0. Podrías ejecutar dicho comando a mano y verificar que tengas el SDK instalado? Fabian Inthamoussu GeneXus Development El 10/07/2012, a las 17:44, PuntoExe | Ing. Juan Marcelo Bustamante Lamas

PuntoExe | Ing. Juan

10/07/12 19:34
Me devuelve la siguiente info: macbookpro$ /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild -version -sdk - Current Mac OS (10.7) () SDKVersion: 10.7 PlatformVersion: 1.0 PlatformPath: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform ProductBuildVersion: 11E53 ProductCopyright: 1983-2012 Apple Inc. ProductName: Mac OS X ProductUserVisibleVersion: 10.7.4 ProductVersion: 10.7.4 MacOSX10.6.sdk - Mac OS X 10.6 (macosx10.6) SDKVersion: 10.6 Path: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.6.sdk PlatformVersion: 1.0 PlatformPath: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform ProductBuildVersion: 10K549 ProductCopyright: 1983-2011 Apple Inc. ProductName: Mac OS X ProductUserVisibleVersion: 10.6.8 ProductVersion: 10.6.8 MacOSX10.7.sdk - Mac OS X 10.7 (macosx10.7) SDKVersion: 10.7 Path: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk PlatformVersion: 1.0 PlatformPath: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform ProductBuildVersion: 11D50a ProductCopyright: 1983-2012 Apple Inc. ProductName: Mac OS X ProductUserVisibleVersion: 10.7.3 ProductVersion: 10.7.3 iPhoneOS5.1.sdk - iOS 5.1 (iphoneos5.1) SDKVersion: 5.1 Path: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk PlatformVersion: 5.1 PlatformPath: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform ProductBuildVersion: 9B176 ProductCopyright: 1983-2012 Apple Inc. ProductName: iPhone OS ProductVersion: 5.1 iPhoneSimulator5.1.sdk - Simulator - iOS 5.1 (iphonesimulator5.1) SDKVersion: 5.1 Path: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator5.1.sdk PlatformPath: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform ProductBuildVersion: 9B176 ProductCopyright: 1983-2012 Apple Inc. ProductName: iPhone OS ProductVersion: 5.1 Xcode 4.3.2 Build version 4E2002 Tanto la de iPhoneOS como la de iPhoneSimulator existen. Saludos El 10 de julio de 2012 18:12, Fabian Inthamoussu

PuntoExe | Ing. Juan

10/07/12 19:44
Creo que descubrí el problema. Yo creé un usuario nuevo en el mac para ponerlo en las propiedades de la KB. Cuando corrí ese comando pero con el usuario creado me pidió primero la aceptación de la licencia. Luego cuando lo volví a correr me devolvió lo mismo que te mandé. Con eso me comenzó a compilar. Muchas gracias a todos!!!! Ing. Juan Marcelo Bustamante Lamas Gerente de Proyectos PuntoExe Consultores www.puntoexe.com.uy Tel: (598-2) 3366612 MSN: ijmbl@hotmail.com Skype: jmblamas http://www.puntoexe.com.uy/sites/puntoexe/firmas/puntologomail.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/platformpartner.jpg http://www.puntoexe.com.uy/sites/puntoexe/firmas/pxlogomail.jpg Migración Win a Web Programación de alto nivel Conocimiento Web Acumulado www.pxtools.com.uy La solución en desarrollo y mantenimiento de sitios web www.epiway.com http://www.puntoexe.com.uy/sites/puntoexe/firmas/epiwaylogomail.jpg

Diego Rostagnol

10/07/12 20:02
Fabián: GeneXus podría detectar esto?? es decir, dar un mejor feedback con respecto a si en realidad no encuentra el SDK 5.0 o si lo que sucedía es lo que le pasó a Marcelo?? Saludos. 2012/7/10 PuntoExe | Ing. Juan Marcelo Bustamante Lamas < jmbl@puntoexe.com.uy> > Creo que descubrí el problema.**** > > Yo creé un usuario nuevo en el mac para ponerlo en las propiedades de la > KB.**** > > Cuando corrí ese comando pero con el usuario creado me pidió primero la > aceptación de la licencia.**** > > Luego cuando lo volví a correr me devolvió lo mismo que te mandé.**** > > ** ** > > Con eso me comenzó a compilar.**** > > ** ** > > Muchas gracias a todos!!!!**** > > ** ** > > *Ing. Juan Marcelo Bustamante Lamas* > *Gerente de Proyectos* > > *PuntoExe Consultores* > www.puntoexe.com.uy > Tel: (598-2) 3366612 > MSN: ijmbl@hotmail.com > Skype: jmblamas **** > > [image: http://www.puntoexe.com.uy/sites/puntoexe/firmas/puntologomail.jpg] > **** > > [image: > http://www.puntoexe.com.uy/sites/puntoexe/firmas/platformpartner.jpg] > **** > ------------------------------ > > [image: http://www.puntoexe.com.uy/sites/puntoexe/firmas/pxlogomail.jpg] > **** > > *Migración Win a Web* > * > **Programación de alto nivel** > **Conocimiento Web Acumulado** > **www.pxtools.com.uy***** > > *La solución en desarrollo y** > **mantenimiento de sitios web** > **www.epiway.com***** > > [image: > http://www.puntoexe.com.uy/sites/puntoexe/firmas/epiwaylogomail.jpg] > **** > ------------------------------ > > ** ** > > *


Back to xev2