anonymous Log in
Search
Recents:
v3.0
gxbrasil-l
Configuração ambiente C# para trabalhar com webservices rest
18/02/20 13:54

luismiyashita

Replies: 5

Renato.
Esse erro pode ter várias origens.
Primeiro verifique se esta utilizando o procotolo correto (http ou https).
Outra origem é o método utilizado na chamada (Get ou Post).
Luis Miyashita.
De: Renato Espíndola <renatoespindola@mti.mt.gov.br>
Enviada em: segunda-feira, 17 de fevereiro de 2020 19:19
Para: GXBrasil-L@gxtech.com.uy
Assunto: [gxbrasil-l] Configuração ambiente C# para trabalhar com webservices rest
Boa noite pessoal.
Além de instalar o URL Rewrite, qual outras configurações são necessárias para que meu webservice rest funcione?
Ao tentar consumir um webservice criado no Genexus X Ev3, gerando para C#, e compilando com o .net framework 4.0 x64, recebo o erro abaixo:
500. System.ServiceModel.ServiceActivationException
--
[https://www.google.com/a/mti.mt.gov.br/images/logo.gif?alpha=1&service=google_black]
Renato Espindola
Analista de T.I
Empresa Mato-grossense de Tecnologia da Informação
CEP: 78049-903 – Palácio Paiaguás – Cuiabá-MT Tel.:+55(65)3613-3020
www.mti.mt.gov.br<https://nam10.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.mti.mt.gov.br%2F&data=02%7C01%7C%7C8736ec600db14437d3c808d7b3f772f5%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637175747691693080&sdata=kPd3apK9Bkby82VtwFg%2FKasgChOLEk7k09jXSlycmzY%3D&reserved=0>
-----------------------------------------
Para Suscribirse/Desuscribirse:
http://br.gxtechnical.com/foros
Por consultas owner-gxbrasil-l@gxtech.com.uy
Replies

renatoespindola

18/02/20 18:43
Boa tarde Luis. Estou utilizando o protocolo http e a chamada estou utilizando post. Na minha máquina local o webservice funciona normalmente. No meu ambiente de Homologação e Produção estou com este erro. Os recursos do WCF estão habilitados no IIS, o rewrite está instalado, e os web.config dos ambientes estão com as mesmas configurações. Já verifiquei os erros possíveis da documentação abaixo: https://wiki.genexus.com/commwiki/servlet/wiki?18398,URLRewrite+-+Common+issues Só não consegui executar o comando para registrar as extensões svc como ele sugere. Me retorna o erro abaixo quando tento executar: [image: image.png] Em ter., 18 de fev. de 2020 às 14:32, Luis Miyashita < luismiyashita@hotmail.com> escreveu: > Renato. > > > > Esse erro pode ter várias origens. > > Primeiro verifique se esta utilizando o procotolo correto (http ou https). > > Outra origem é o método utilizado na chamada (Get ou Post). > > > Luis Miyashita. > > > > *

psansivi

18/02/20 21:06
> > > Renato, > > Acho que precisa ligar o WCF Activation da versão correspondente ao > framework que você usa no POOL pela interface do sistema operacional. Estes > comando pelo "DOS" não funcionam nas versões mais novas de SO. > > No meu Windows 10 fiz assim: > > [image: image.png] > > Att, > Paulo > > > > >> ---------- Forwarded message --------- >>

luismiyashita

18/02/20 18:59
Verifique os erros passo-a-passo: Consegue acessar o WSDL dos ambiente com erro?? http://dominio/meuwebserivce.aspx?wsdl Consegue acessar alguma página da aplicação? Luis Miyashita.

renatoespindola

19/02/20 12:40
Bom dia Luis. Tenho outros webservices com wsdl acessíveis neste mesmo ambiente com erro. Somente os webservices rest me apresentam o erro. Esta aplicação possui somente webservices. Em qua., 19 de fev. de 2020 às 00:03, Luis Miyashita < luismiyashita@hotmail.com> escreveu: > Verifique os erros passo-a-passo: > > > Consegue acessar o WSDL dos ambiente com erro?? > http://dominio/meuwebserivce.aspx?wsdl > > Consegue acessar alguma página da aplicação? > > Luis Miyashita. > > > > *

luismiyashita

19/02/20 17:06
Ok. Já testou se o serviço rest esta respondendo?? http://dominio/rest/servicorest Luis Miyashita.


Back to gxbrasil-l