anonymous Log in
Search
Recents:
v3.0
csharp-l
Problema External Object SP GX16U3 iSeries
27/09/19 14:19

Alrnoldo Schwarz

Replies: 0

Buenos días
Tengo una KB en Gx16U3 generando .net con SQL Server y un Datastore adicional que conecta a un iSeries.
Defini un External object de tipo Stored Procedure que llama a un CL en el AS400, el SP esta apuntado obviamente al iSeries.
Ahora bien, tengo un webpanel solo tiene un boton que llama al Stored Procedure:
&SP.XXXXX() 
Haciendo pruebas, vi que si el CL no tiene paramentros anda todo bien, dispara el CL y no cancela el panel y tengo la respuesta correcta en el AS400.
El problema se presenta cuando le agrego un parametro al CL; hago lo mismo con el external object, defino ademas el CL en la lista de stored procedures de las propiedades del data store y ejecuto ademas el create
CREATE PROCEDURE XXXXX(INOUT CHAR(1)) EXTERNAL NAME XXXXX LANGUAGE RPG GENERAL
Pero cuando llamo, &SP.XXXXX(&Parm1) 
el panel pincha y me tira el error "Could not find Stored Procedure XXXXX"
No logro descifrar que me puede estar faltando, ya que lo hice mil veces con GX9 y nunca tuve problemas siguiendo los mismos pasos.
Estuve buscando en los SACs, foros, etc pero no encontre demasiada información adicional.
Agradecería cualquier ayuda del caso.
Saludos
Andres Schwarz
-----------------------------------------
Para Suscribirse/Desuscribirse:
http://www.gxtechnical.com/cgi-bin/hforum.exe?2,3,30,11
Por consultas owner-csharp-l@gxtech.com.uy


Back to csharp-l