anonymous Log in
Search
Recents:
v3.0
gxquery-l
GXquery 4.0 U6 Build 615. Error en la importaciónde una metadata
05/09/16 14:22

Jorge.Izquierdo@gms.

Replies: 9


Estimados, qué tal ?

Tengo GXquery 4.0 U

Generé desde GX X Evo 3 U 7 una metadata con la opción "Connect to GXquery"
Entré a GXquery, vi que estaba la metada que creé pero salió en la columna
estado "Falló la carga"

Entré a GX, actualicé la metadata con la opción "Save locally"
Le puse Actualizar la metadata y al final me dio los siguientes errores:

Gracias por cualquier comentario/sugerencia ?

Importing Language 'Spanish'... Successful
Importing Transaction 'Customer'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Transaction 'Country'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Transaction 'Attraction'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Transaction 'Category'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Transaction 'Trip'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Transaction 'Prize'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Transaction 'Airport'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Transaction 'Flight'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Transaction 'Airline'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Transaction 'Supplier'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Transaction 'ServiceCard'... Failed
>>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified.
Importing Subtype Group 'FlightDepartureAirport'... Successful
Importing Subtype Group 'FlightArrivalAirport'... Successful
========== Import objects finished: Failed ==========
========== Import metadata finished: Failed ==========


Gracias por cualquier comentario/sugerencia ?


Saludos,

Jorge Izquierdo


Salud

---------------------------------------
Para Suscribirse/Desuscribirse:
http://www.gxtechnical.com/cgi-bin/hforum.exe?2,3,30
Por consultas owner-gxquery-l@gxtech.com.uy
Replies

gmartinez

05/09/16 14:52
Jorge, qué tal? Tenemos un error con el mismo texto reportado y corregido en la versión 4.0.446.7 de la extension de GXquery. Todavía no está en el Marketplace la versión así que te paso este link para que puedas bajártela: http://archivos.artech.com.uy/gmartinez/GXqueryExtensionXEv3.zip Por favor prueba y me comentas si se te solucionó o sigues con el problema. Saludos. Gustavo Martínez GeneXus. 2016-09-05 11:22 GMT-03:00 Jorge Izquierdo : > Estimados, qué tal ? > > Tengo GXquery 4.0 U > > Generé desde GX X Evo 3 U 7 una metadata con la opción "Connect to GXquery" > Entré a GXquery, vi que estaba la metada que creé pero salió en la columna > estado "Falló la carga" > > Entré a GX, actualicé la metadata con la opción "Save locally" > Le puse Actualizar la metadata y al final me dio los siguientes errores: > > Gracias por cualquier comentario/sugerencia ? > > Importing Language 'Spanish'... Successful > Importing Transaction 'Customer'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Transaction 'Country'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Transaction 'Attraction'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Transaction 'Category'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Transaction 'Trip'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Transaction 'Prize'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Transaction 'Airport'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Transaction 'Flight'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Transaction 'Airline'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Transaction 'Supplier'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Transaction 'ServiceCard'... Failed > >>>ERROR: Could not load file or assembly 'Artech.Patterns.WorkWithDevices, Version=10.1.0.0, Culture=neutral, PublicKeyToken=6f5bf81c27b6b8aa' or one of its dependencies. The system cannot find the file specified. > Importing Subtype Group 'FlightDepartureAirport'... Successful > Importing Subtype Group 'FlightArrivalAirport'... Successful > ========== Import objects finished: Failed ========== > ========== Import metadata finished: Failed ========== > > > Gracias por cualquier comentario/sugerencia ? > > > Saludos, > > Jorge Izquierdo > > > Salud > > --------------------------------------- Para Suscribirse/Desuscribirse: http://www.gxtechnical.com/cgi-bin/hforum.exe?2,3,30 Por consultas owner-gxquery-l@gxtech.com.uy

Jorge.Izquierdo@gms.

05/09/16 15:11
Hola Gustavo. Gracias por el dato. Donde lo descargo ? [image: Imagen integrada 1] *Jorge Izquierdo* Jefe de Línea GeneXus jorge.izquierdo@gms.com.ec Oficina: +593 2 399-3000 Ext. 7510 Celular: +593 99 993-6846 *www.gms.com.ec * [image: Twitter] [image: Facebook] [image: Twitter] El 5 de septiembre de 2016, 09:51, Gustavo Martínez

gmartinez

05/09/16 15:19
Descomprimilo en el directorio de GeneXus en la carpeta Packages. Saludos. Gustavo. El 5 de septiembre de 2016, 12:10, Jorge Izquierdo < jorge.izquierdo@gms.com.ec>

Jorge.Izquierdo@gms.

05/09/16 15:36
Preguntaba porque mencionaste "...versión 4.0.446.7 de la *extension *de GXquery." y el link también tiene por ahí "extension". En todo caso descomprimí el zip en: C:\GXquery40\Web\BinGeneXus\Packages Mirando en licencias: [image: Imagen integrada 2] No veo que se haya cambiado el Build, sigue con 615, no se si es correcto eso. [image: Imagen integrada 1] Le hice un update a la metadata en GXquery y no se arregló. Borré la metadata que se creó en GXquery Creé una nueva metadata con otro nombre pero sigue el mismo problema. Jorge El 5 de septiembre de 2016, 10:18, Gustavo Martínez

gmartinez

05/09/16 15:42
No. El build de GXquery no va a cambiar (va a seguir siendo 615). Tienes que fijarte en GeneXus, en Tools -> Extension Manager de GeneXus que la versión levantada sea la *4.0.446.7* Si la exportación de la metadata realmente fue generada con esa versión de la extension y sigue sin funcionarte, pásamela que la reviso. Saludos Gustavo. El 5 de septiembre de 2016, 12:36, Jorge Izquierdo < jorge.izquierdo@gms.com.ec>

gmartinez

05/09/16 15:48
Tal vez me faltó aclarar que la exportación de la metadata que ya tienes NO SIRVE. Tienes que volver a generarla con la versión 4.0.446.7 de la extension y esa es la que hay que cargar en GXquery. Saludos. Gustavo. El 5 de septiembre de 2016, 12:42, Gustavo Martínez

Jorge.Izquierdo@gms.

05/09/16 16:45
Quizá algo no hice bien: 1. Tenía abierto GX 2. Hice el unzip 3. Probé y nada 4. Recién cerré GX y vi el Extension Manager [image: Imagen integrada 1] Pero sale ".6" y no ".7" Luego ejecuté el instalador de GXquery para hacer un update Volví a hacer el unzip y sigue saliendo la ".6" De otro lado, es correcto que en la carpeta BinGeneXus exista una carpeta "ja-JP" (tiene 26 dlls) ? [image: Imagen integrada 1] Finalmente, luego del unzip tengo: [image: Imagen integrada 2] y dentro de la carpeta C:\GXquery40\Web\BinGeneXus\Packages\ja-JP tiene: [image: Imagen integrada 3] Gracias. De pronto desinstalo GXquery y pruebo de vuelta ? ?Saludos, Jorge? El 5 de septiembre de 2016, 10:42, Gustavo Martínez

ab7723

05/09/16 16:48
Hola Jorge, quizás te faltó ejecutar genexus.exe /install ? Saludos, Armin 2016-09-05 13:45 GMT-03:00 Jorge Izquierdo : > Quizá algo no hice bien: > > 1. Tenía abierto GX > 2. Hice el unzip > 3. Probé y nada > > 4. Recién cerré GX > y vi el Extension Manager > > [image: Imagen integrada 1] > > Pero sale ".6" y no ".7" > > Luego ejecuté el instalador de GXquery para hacer un update > Volví a hacer el unzip > y sigue saliendo la ".6" > > > > > De otro lado, es correcto que en la carpeta BinGeneXus exista una carpeta > "ja-JP" (tiene 26 dlls) ? > > [image: Imagen integrada 1] > > > Finalmente, luego del unzip tengo: > > [image: Imagen integrada 2] > y dentro de la carpeta C:\GXquery40\Web\BinGeneXus\Packages\ja-JP > tiene: > > [image: Imagen integrada 3] > > Gracias. > > De pronto desinstalo GXquery y pruebo de vuelta ? > > ?Saludos, > > Jorge? > > > > El 5 de septiembre de 2016, 10:42, Gustavo Martínez >

gmartinez

05/09/16 16:53
Perdón, capaz que no me expliqué bien. No tenés que hacer absolutamente NADA con la carpeta donde tenés instalado GXquery o alguno de sus archivos. El cambio es en la carpeta donde tenés instalado GeneXus. Primero que nada, descomprime el zip que bajaste y verifica que las dlls que contiene tienen la version 4.0.446.7. Luego sustituye en la carpeta Packages de GeneXus las dlls que ya hay por las nuevas. Luego abres GeneXus, y en el Extension Manager te tiene que decir versión 4.0.446.7 para la extension de GXquery. Si te sigue diciendo 4.0.446.6 es que las dlls no fueron sustituidas. Fíjate si ahora puedes. Saludos. Gustavo. El 5 de septiembre de 2016, 13:45, Jorge Izquierdo < jorge.izquierdo@gms.com.ec>


Back to gxquery-l