anonymous Log in
Search
Recents:
v3.0
gxenglish-l
Oracle connection problems
12/12/14 10:10

Stefano Broggi

Replies: 1


Hi everybody,

I'm experiencing a very frustrating problem when trying to connect to an Oracle DB from a Genexus10 web application.

The application was developed originally with Genexus9 in a 32 bits environment (Windows XP), and connected to an Oracle8 database (32 bits too).
Then the application was migrated to Genexus10 Evolution2, keeping the same 32 bit environment.
Finally it was migrated to a new 64 bits machine running Window 7 with .Net Framework from 2.0.xxx to 4.0, both 32 and 64 bits version.
I installed a local 64 bits Oracle 11g DB, plus the 64 bits Oracle 11g Client.

I set an Oracle Datastore (under .Net Environment entry within Preferences View), defining "ADO.Net" as Access Technology, and "Microsoft Data Provider" as ADO.Net Provider,
plus the database connection parameters. I tested connection and I got this reply:
"Attempt to load Oracle client liberaries threw BadImageFormatException.
This problem will occur when running in 64 bit mode with the 32 bit Oracle client components installed (System.Data.OracleClient)"

I searched the web and I found that Microsoft Oracle Client is a deprecated technology, and the suggestion was to install ODAC (Oracle Data Access Components)
I did it, then I set "Oracle Data Provider" as ADO.Net Provider, I tested connection, but reply was just the same.

Now I'm confused: it seems to me that ADO.Net it's still using Microsoft Oracle Client, as the error message still refers to "System.Data.OracleClient".
How could I force ADO.Net to use Oracle "native" Client?

On another way, how could I force ADO.Net to use the 64 bits release of the System.Data.OracleClient?


Thank you very much in advance for your help (and please excuse me for my bad English).


Stefano

Replies

lmurillo

12/12/14 13:11
Hi Stefano, we have fixed same bugs related to .Net generator/Oracle and 32/64 bits. Are you using a GeneXus version previous to GX X ev2 U2, because the corrections was made in upgrade 2. Anyway, can you test setting /platform:x64 in the property Compiler Flags? Regards, Luis *


Back to gxenglish-l