anonymous Log in
Search
Recents:
v3.0
gx-l
Erro ao compilar em Xcode 11.4 - Could not find 'ffi' (>= 1.3.0)
20/11/20 19:49

mpp.ata12647

Replies: 0

Olá estou com um problema ao compilar um app em gx 16 u10.
Estava tudo funcionando, após atualizar O.s do para Big Sur 11.0.1, começou a acontecer o erro.
Log do output do build:
2020-11-20 15:45:04,107: INFO - Conectando-se a 192.168.0.111
2020-11-20 15:45:10,805: INFO - Copiando Bibliotecas para /Users/t.i/Library/GeneXus/GeneXus/16.0.142546_U10/
2020-11-20 15:45:27,615: INFO - Sincronizando c:\models\ij-u10\net\mobile\iOS\EI\ios\Genexus para /Users/t.i/Documents/Projects/iju10/app2/EI
2020-11-20 15:45:34,593: ERROR - error: /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/dependency.rb:311:in `to_specs': Could not find 'ffi' (>= 1.3.0) among 126 total gem(s) (Gem::MissingSpecError)
2020-11-20 15:45:34,596: ERROR - error: Checked in 'GEM_PATH=/Users/t.i/.gem/ruby/2.6.0:/Library/Ruby/Gems/2.6.0:/System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/gems/2.6.0', execute `gem env` for more information
2020-11-20 15:45:34,596: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1449:in `block in activate_dependencies'
2020-11-20 15:45:34,596: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `each'
2020-11-20 15:45:34,597: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `activate_dependencies'
2020-11-20 15:45:34,597: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1420:in `activate'
2020-11-20 15:45:34,597: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1452:in `block in activate_dependencies'
2020-11-20 15:45:34,597: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `each'
2020-11-20 15:45:34,597: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `activate_dependencies'
2020-11-20 15:45:34,598: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1420:in `activate'
2020-11-20 15:45:34,598: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1452:in `block in activate_dependencies'
2020-11-20 15:45:34,598: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `each'
2020-11-20 15:45:34,598: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `activate_dependencies'
2020-11-20 15:45:34,598: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1420:in `activate'
2020-11-20 15:45:34,599: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1452:in `block in activate_dependencies'
2020-11-20 15:45:34,599: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `each'
2020-11-20 15:45:34,599: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1438:in `activate_dependencies'
2020-11-20 15:45:34,599: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems/specification.rb:1420:in `activate'
2020-11-20 15:45:34,600: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems.rb:304:in `block in activate_bin_path'
2020-11-20 15:45:34,600: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems.rb:303:in `synchronize'
2020-11-20 15:45:34,600: ERROR - error: from /System/Library/Frameworks/Ruby.framework/Versions/2.6/usr/lib/ruby/2.6.0/rubygems.rb:303:in `activate_bin_path'
2020-11-20 15:45:34,601: ERROR - error: from /usr/local/bin/pod:23:in `<main>'
2020-11-20 15:45:34,761: INFO - Failed: iOS Compilation
Como resolvo isso?
Agradeço desde já, obrigado.
Marcos Pedro
Extralife Soluções em Informática
(18) 99615-6083
-----------------------------------------
Para Suscribirse/Desuscribirse:
http://www.gxtechnical.com/cgi-bin/hforum.exe?2,3,30,1
Por consultas owner-gx-l@gxtech.com.uy


Back to gx-l