anonymous Log in
Search
Recents:
v3.0
gx-l
QueryViewer Table - Não respeita a Picture quando tem valor negativo
09/10/20 15:09

gmartinez

Replies: 5

Olá Danilo.
O caracter para indicar o separador de miles na picture é a *coma*, nao o
ponto, e é independentemente do idioma (
https://wiki.genexus.com/commwiki/servlet/wiki?36522,Picture%20property)
A picture correta sería *ZZZ,ZZZ,ZZZ* ou *ZZZ,ZZZ,ZZ9 *
Abraço
Gustavo Martínez
GeneXus.
El vie., 9 oct. 2020 a las 11:44, Danilo Martinez do Nascimento (<
danilomartnas@gmail.com>) escribió:
> Olá Pessoal!
>
> Tenho uma queryviewer do tipo table, com colunas tipo data (tanto faz se
> mudar para row), picture difina como ZZZ.ZZZ.ZZZ, e o valor que vem do
> banco de dados pode vir também com valor negativo.
>
> Quando o valor atinge o separador de milhar e é negativo, aparece o "."
> separando o sinal de negativo ... em queryviewer do tipo pivot table não
> acontece isso, mas não posso usar pois ela cria a linha de total e não
> posso ter essa linha de total no final.
>
> [image: image.png]
>
> Alguém tem alguma sugestão?
>
> Desde já obrigado pela atenção
>
> Att
> Danilo
>
Replies

d-martinez

09/10/20 16:28
Olá Gustavo. A picture está correta, só escrevi errada na hora de montar o e-mail ZZZ,ZZZ,ZZZ,ZZZ,ZZ9 O problema é que valores negativos estão aparecendo com a picture errada. Exemplo: *-100.520,10* Está mostrando *-.100.520,00 ---> "-."* Att Danilo Em sex., 9 de out. de 2020 às 12:10, Gustavo Martínez escreveu: > Olá Danilo. > O caracter para indicar o separador de miles na picture é a *coma*, nao o > ponto, e é independentemente do idioma ( > https://wiki.genexus.com/commwiki/servlet/wiki?36522,Picture%20property) > A picture correta sería *ZZZ,ZZZ,ZZZ* ou *ZZZ,ZZZ,ZZ9 * > Abraço > Gustavo Martínez > GeneXus. > > El vie., 9 oct. 2020 a las 11:44, Danilo Martinez do Nascimento (< > danilomartnas@gmail.com>)

gmartinez

13/10/20 17:23
Olá Danilo! Tudo bem? Com qué versão de GeneXus voce está? Porque nao estou podendo reproduzir o problema. Testei com v16u10, v16u11 e v17 e a picture com *table* parece estar funcionando bem: [image: image.png] Abraço Gustavo Martínez GeneXus. El vie., 9 oct. 2020 a las 13:29, Danilo Martinez do Nascimento (< danilomartnas@gmail.com>)

d-martinez

13/10/20 23:13
Olá Gustavo! GX 15 U12 WWP 12.21 C#.NET Att Danilo Em ter., 13 de out. de 2020 às 14:24, Gustavo Martínez < gmartinez@genexus.com> escreveu: > Olá Danilo! > Tudo bem? > Com qué versão de GeneXus voce está? > Porque nao estou podendo reproduzir o problema. > Testei com v16u10, v16u11 e v17 e a picture com *table* parece estar > funcionando bem: > > [image: image.png] > > Abraço > Gustavo Martínez > GeneXus. > > > > El vie., 9 oct. 2020 a las 13:29, Danilo Martinez do Nascimento (< > danilomartnas@gmail.com>)

gmartinez

14/10/20 13:09
Olá Danilo. O problema foi resolvido no *GeneXus 16 Upgrade 6*. Atenciosamente Gustavo Martínez GeneXus. El mar., 13 oct. 2020 a las 20:14, Danilo Martinez do Nascimento (< danilomartnas@gmail.com>)

d-martinez

14/10/20 17:21
Obrigado Gustavo! Em qua., 14 de out. de 2020 às 10:09, Gustavo Martínez < gmartinez@genexus.com> escreveu: > Olá Danilo. > O problema foi resolvido no *GeneXus 16 Upgrade 6*. > Atenciosamente > Gustavo Martínez > GeneXus. > > El mar., 13 oct. 2020 a las 20:14, Danilo Martinez do Nascimento (< > danilomartnas@gmail.com>)


Back to gx-l