anonymous Log in
Search
Recents:
v3.0
postgresql-l
GAM y postgres funcionan juntos????
31/05/12 22:01

martinsilvait

Replies: 1

Hola, estoy comenzando con genexus y tratando de hacer andar el GAM contra postgres. He generado una aplicación, y pude generar usuarios en el gam, dar permisos, roles, etc. De repente, no se qué cambié y no me dejó más modificar ni agregar usuarios, si roles y permisos pero no usuarios. Y no encuentro errores en el log de tomcat. Eso me pasó en postgres 9.1. Instalé 8.3 por si era problema de la versión y al ingresar a la pantalla de login muestra el error "Connection not found. (GAM30)" sin mostrar mensajes en el log. También veo que el gam se conecta de forma diferente a la aplicación, ya que puedo trabajar con mis transacciones sin problemas si el Default integrated security es "none". Si alguien me puede ayudar con un ejemplo de cómo conectar, he intentado con custom driver, con el driver que trae, con jdbc datasource y configurando el tomcat con el jndi y no logro hacerlo andar. La forma en que funciona en forma parcial es con el jdbc.jar (ya sea para la versión 8.3 o 9.1) de postgres en el lib del tomcat y nada más. Como es una aplicación nueva prefiero usar la versión más nueva de la base de datos, además para aprovechar el tema de la réplica de la versión 9, pero de última necesito que ande como sea. Si alguien tiene un ejemplo agradezco ya he dedicado algunos días a esto y no se que mas probar. Saludos y gracias, Martín ----------------------------------------- Para Suscribirse/Desuscribirse: http://www.gxtechnical.com/cgi-bin/hforum.exe?2,3,30,24 Por consultas owner-postgresql-l@gxtech.com.uy
Replies

martinsilvait

31/05/12 23:59
Hola, estoy comenzando con genexus y tratando de hacer andar el GAM contra postgres. He generado una aplicación, y pude generar usuarios en el gam, dar permisos, roles, etc. De repente, no se qué cambié y no me dejó más modificar ni agregar usuarios, si roles y permisos pero no usuarios. Y no encuentro errores en el log de tomcat. Eso me pasó en postgres 9.1. Instalé 8.3 por si era problema de la versión y al ingresar a la pantalla de login muestra el error "Connection not found. (GAM30)" sin mostrar mensajes en el log. También veo que el gam se conecta de forma diferente a la aplicación, ya que puedo trabajar con mis transacciones sin problemas si el Default integrated security es "none". Si alguien me puede ayudar con un ejemplo de cómo conectar, he intentado con custom driver, con el driver que trae, con jdbc datasource y configurando el tomcat con el jndi y no logro hacerlo andar. La forma en que funciona en forma parcial es con el jdbc.jar (ya sea para la versión 8.3 o 9.1) de postgres en el lib del tomcat y nada más. Como es una aplicación nueva prefiero usar la versión más nueva de la base de datos, además para aprovechar el tema de la réplica de la versión 9, pero de última necesito que ande como sea. Si alguien tiene un ejemplo agradezco ya he dedicado algunos días a esto y no se que mas probar. Saludos y gracias, Martín ----------------------------------------- Para Suscribirse/Desuscribirse: http://www.gxtechnical.com/cgi-bin/hforum.exe?2,3,30,24 Por consultas owner-postgresql-l@gxtech.com.uy


Back to postgresql-l